tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karan Malhi" <karan.ma...@gmail.com>
Subject Re: Incompatibility between openejb 3.0 and hibernate 3.2.6a
Date Thu, 31 Jul 2008 11:00:35 GMT
Wonderful,

Thanks again. Updated the wiki with this info.

On Thu, Jul 31, 2008 at 2:51 AM, Christian Schuhegger <
Christian.Schuhegger@gmx.de> wrote:

> Hello,
>
> this is not really related to openejb directly, but I thought it might help
> other users that use openejb.
>
> I tried to use openejb 3.0 together with hibernate 3.2.6ga in a maven
> project. The transitive dependencies of openejb and hibernate collide on
> asm.jar. A similar problem is described here:
>
> http://blog.springsource.com/main/2007/06/11/asm-version-incompatibilities-using-spring-autowired-with-hibernate/
> or here:
>
> http://forum.springframework.org/showthread.php?t=26713&highlight=cglib-nodep+hibernate
> http://jira.springframework.org/browse/SPR-3856
>
> The solution is to exclude the dependency on asm and cglib on hibernate and
> to add a dependency on cglib-nodep.
>
> Just fyi,
> --
> Christian Schuhegger
> http://www.el-chef.de/
>



-- 
Karan Singh Malhi

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message