tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From afryer <apfr...@hotmail.com>
Subject Should javax.mail api be included in javaee-api 6.0-2?
Date Mon, 28 Nov 2011 02:16:16 GMT
I have a test case in a project that uses javax.mail that uses embedded
openejb (openejb-core 4.0.0-beta-1).  I found that to get openejb to work in
the test case, I had to change my maven dependencies from using
javax:javaee-web-api:6.0 to use org.apache.openejb:javaee-api:6.0-2.  I then
discovered that this no longer included the javax.mail api, so my build
started failing.

I tried adding the standard javax.mail:mail:1.4.4 dependency, but then
embedded openejb couldn't create the default mail session, so I eventually
ended up using geronimo-javamail_1.4_mail which got everything working
again.

My question is, shouldn't the javaee-api:6.0-2 already include the
javax.mail api?

--
View this message in context: http://openejb.979440.n4.nabble.com/Should-javax-mail-api-be-included-in-javaee-api-6-0-2-tp4113924p4113924.html
Sent from the OpenEJB User mailing list archive at Nabble.com.

Mime
View raw message