tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jolinnen <jo...@linnenkohl.org>
Subject TomEE 7.0.3. : Requests are rejected
Date Tue, 22 May 2018 15:32:45 GMT
Hello,
since this year we use an uptime monitor for our webservice. From time to
time this monitor reports that our service is unavailable for just a short
time.
I see in our logfiles (and even in catalina.out), that the service is still
online at this time, but it seems that some requests are rejected.

In  localhost_access_log I found entries like this:

194.187.221.160 - - [22/May/2018:14:31:51 +0200] "GET /OurService/version
HTTP/1.1" 200 47
194.187.221.160 - - [22/May/2018:14:35:28 +0200] "GET /OurService/version
HTTP/1.1" 200 47
194.187.221.160 - - [22/May/2018:14:37:02 +0200] "GET /OurService/version
HTTP/1.1" 200 47
*194.187.221.160 - - [22/May/2018:14:40:36 +0200] "GET /OurService/version
HTTP/1.1" 500 73*
194.187.221.160 - - [22/May/2018:14:40:36 +0200] "GET /OurService/version
HTTP/1.1" 200 47
194.187.221.160 - - [22/May/2018:14:42:26 +0200] "GET /OurService/version
HTTP/1.1" 200 47

and in catalina.out I can see an entry for the requests with HTTP status
200, but not for the 500 status. So my guess is that the uptime monitor
complains about this.

We are using default parameters in server.xml.

Have someone an idea what's happened? Should we increase maxThreads or what
ever?  Is there a possibility for getting more information about the reason
for the rejects?

Many thanks in advance

Cheers

Jörg



 



--
Sent from: http://tomee-openejb.979440.n4.nabble.com/TomEE-Users-f979441.html

Mime
View raw message