trafficserver-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iga...@apache.org
Subject git commit: extend readme install instructions, in particular for FreeBSD.
Date Mon, 04 Feb 2013 18:43:41 GMT
Updated Branches:
  refs/heads/master f719d5c61 -> 88679d783


extend readme install instructions, in particular for FreeBSD.


Project: http://git-wip-us.apache.org/repos/asf/trafficserver/repo
Commit: http://git-wip-us.apache.org/repos/asf/trafficserver/commit/88679d78
Tree: http://git-wip-us.apache.org/repos/asf/trafficserver/tree/88679d78
Diff: http://git-wip-us.apache.org/repos/asf/trafficserver/diff/88679d78

Branch: refs/heads/master
Commit: 88679d783e964eca45edd31cb91a9bfd483f63ca
Parents: f719d5c
Author: Igor Galić <i.galic@brainsware.org>
Authored: Mon Feb 4 19:43:26 2013 +0100
Committer: Igor Galić <i.galic@brainsware.org>
Committed: Mon Feb 4 19:43:26 2013 +0100

----------------------------------------------------------------------
 README |   31 ++++++++++++++++---------------
 1 files changed, 16 insertions(+), 15 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/trafficserver/blob/88679d78/README
----------------------------------------------------------------------
diff --git a/README b/README
index 3f99d1a..561097f 100644
--- a/README
+++ b/README
@@ -91,7 +91,7 @@ plugins to build large scale web applications.
     libcap-dev
 	flex (optional)
     libhwloc-dev (optional)
-    liblua5.1-dev (optional)
+    liblua5.1-dev or libluajit-5.1-dev (optional)
 
   Ubuntu EC2 9.10:
     NOTE: Alternately you may use the install scripts in 'contrib' which
@@ -114,20 +114,21 @@ plugins to build large scale web applications.
     libhwloc-dev (optional)
     liblua-dev (optional)
 
-  FreeBSD 7.2,8.0,9.0:
-    GCC 4.2.1 compiler suite or clang
-    gmake
-    autoconf
-    automake
-    pkgconf
-    libtool
-    tcl
-    expat
-    openssl
-    pcre
-	flex (optional)
-    hwloc (optional)
-    lua (optional)
+  FreeBSD 7.2,8.0,9.0,9.1
+    GCC 4.2.1 compiler suite or clang. You can install the following
+	packages either from ports or via pkg_add or pkgng:
+    devel/gmake
+    devel/autoconf
+    devel/automake
+    devel/pkgconf
+    devel/libtool
+    lang/tcl85
+    textproc/expat (or expat2)
+    security/openssl
+    devel/pcre
+    textproc/flex (optional, install newer version from ports, fix PATH)
+    devel/hwloc (optional)
+    lang/lua (optional, on x64 don't use LuaJIT!)
 
   OpenSolaris osol0906:
     GCC 4.3.2 compiler suite (dev collection)


Mime
View raw message