trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eagen, Dave" <David.Ea...@biworldwide.com>
Subject RE: 502 errors with DIRECT connections
Date Tue, 03 May 2011 13:38:41 GMT
I also have these requests logged with the ttms field (last one in the line):

2011-05-03 07:44:21 CONNECT interface.gta-travel.com:443/ HTTP/1.1 CONNECT CODE=200 6760 762
2011-05-03 07:44:22 CONNECT interface.gta-travel.com:443/ HTTP/1.1 CONNECT CODE=502 231 79
2011-05-03 07:44:25 CONNECT interface.gta-travel.com:443/ HTTP/1.1 CONNECT CODE=200 77207
5949

So apparently it's not a timeout issue since the 502 happens after 79ms while the successful
requests take 762 to 6000 ms. What else could be causing this?

-Dave

From: Eagen, Dave [mailto:David.Eagen@biworldwide.com]
Sent: Tuesday, May 03, 2011 8:21 AM
To: users@trafficserver.apache.org
Subject: 502 errors with DIRECT connections

We continue to see occasional 502 errors on DIRECT connections to sites. These never happen
when running through Squid so there is some difference between ATS and Squid. Examples:

1304426660.849 1322 172.16.88.240 TCP_MISS/200 11469 CONNECT interface.gta-travel.com:443/
- DIRECT/interface.gta-travel.com - -
1304426661.614 762 172.16.88.240 TCP_MISS/200 6869 CONNECT interface.gta-travel.com:443/ -
DIRECT/interface.gta-travel.com - -
1304426662.759 79 172.16.88.240 ERR_CONNECT_FAIL/502 460 CONNECT interface.gta-travel.com:443/
- DIRECT/interface.gta-travel.com text/html -
1304426665.474 5949 172.16.88.240 TCP_MISS/200 77316 CONNECT interface.gta-travel.com:443/
- DIRECT/interface.gta-travel.com - -

The connection failure (502) only occurs when using traffic server and it does not occur every
time. This was happening as far back as 2.1.5 and is still happening with the 2.1.8 release
candidate. It's unfortunately preventing us from moving to ATS.

Is there some timeout parameter that needs to be modified to match whatever Squid is using
by default? We tried changing proxy.config.http.connect_attempts_timeout to 30 instead of
the default 20 but that didn't fix the issue.

-Dave


This e-mail message is being sent solely for use by the intended recipient(s) and may contain
confidential information. Any unauthorized review, use, disclosure or distribution is prohibited.
If you are not the intended recipient, please contact the sender by phone or reply by e-mail,
delete the original message and destroy all copies. Thank you.

This e-mail message is being sent solely for use by the intended recipient(s) and may contain
confidential information.  Any unauthorized review, use, disclosure or distribution is prohibited.
 If you are not the intended recipient, please contact the sender by phone or reply by e-mail,
delete the original message and destroy all copies. Thank you.
Mime
View raw message