trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Van Doorn, Jan R" <>
Subject Re: Maximum Disk Cache size?
Date Thu, 05 Jul 2012 17:20:01 GMT
Opened TS-1319 for this.

I did some digging, and it seems the size in iocore/cache/P_CacheVol.h is rolling over?

Here's the definition:

struct CacheVol
  int vol_number;
  int scheme;
  int size;
  int num_vols;
  Vol **vols;
  DiskVol **disk_vols;
  LINK(CacheVol, link);
  // per volume stats
  RecRawStatBlock *vol_rsb;

    : vol_number(-1), scheme(0), size(0), num_vols(0), vols(NULL), disk_vols(0), vol_rsb(0)
  { }

If I change this to off_t, and the Debug print that uses it as well, it seems to all be working.
Diff for 3.2.0:

diff -r ./iocore/cache/ ../../trafficserver-3.2.0/iocore/cache/

< Debug("cache_hosting", "Host Record: %p, Volume: %d, size: %u", this, cachep->vol_number,
> Debug("cache_hosting", "Host Record: %p, Volume: %d, size: %jd", this, cachep->vol_number,

diff -r ./iocore/cache/P_CacheVol.h ../../trafficserver-3.2.0/iocore/cache/P_CacheVol.h
< int size;
> off_t size;


On 06/22/2012 10:04 PM, Leif Hedstrom wrote:

On Jun 21, 2012, at 4:08 PM, "Van Doorn, Jan R" <><>


Is there a maximum disk cache size in ATS 3.20? I seem to be getting

The only people I know with such big caches are Taobao. I certainly have nothing remotely
close to this :). Definitely sounds like a bug, so pease file a ticket. The cache is supposed
to handle up to 0.5PB volumes if I recall.

Bart, did you ever commit that fix for very large partitions?


-- Leif

[TrafficServer] using root directory '/opt/trafficserver'
[Jun 21 21:57:10.038] {0x7f4d67aa67e0} STATUS: opened
[Jun 21 21:57:10.038] {0x7f4d67aa67e0} NOTE: updated diags config
[Jun 21 21:57:10.042] Server {0x7f4d67aa67e0} NOTE: cache clustering
[Jun 21 21:57:10.083] Server {0x7f4d67aa67e0} NOTE: cache clustering
[Jun 21 21:57:10.182] Server {0x7f4d67aa67e0} NOTE: logging
initialized[11], logging_mode = 3
[Jun 21 21:57:10.183] Server {0x7f4d67aa67e0} NOTE: loading plugin
[Jun 21 21:57:10.185] Server {0x7f4d67aa67e0} NOTE: traffic server running
[Jun 21 21:57:10.189] Server {0x7f4d63799700} WARNING: not enough space
to increase volume: [1] to size: [20585472]
[Jun 21 21:57:10.189] Server {0x7f4d63799700} NOTE: edit the
volume.config file and restart traffic_server
[Jun 21 21:57:10.189] Server {0x7f4d63799700} NOTE: cache disabled

When I try to use more than a certain amount (16TB?) of cache, and the
"cache disabled" message doesn't seem good.

I have a system with 24 600GB drives that works well, but a system with
24 900GB drives will have the above error, unless I disable at least 5
drives in storage.config.

I tried splitting the cache up in to 2 volumes, each 50% in
volume.config, but I still get the same error.

Thanks again,

View raw message