trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Andrews <comptech1...@gmail.com>
Subject Re: Dynamic Caching Issue
Date Sat, 27 Mar 2021 21:21:22 GMT
Everything on the server is mostly default. It just seems as, from what I
can gather, the redirect reply isn't sending the fully configured url
despite having that configuration as instructed. I'm not quite sure where
else to look or tweak.

Let me know if the details I sent weren't sufficient.

On Sat, Mar 27, 2021 at 5:00 PM Patrick Andrews <comptech1988@gmail.com>
wrote:

> Hey Miles,
>
> Curl from the server:
> [image: image.png]
>
> and the response I'm getting on my service box is as follows:
>
> [image: image.png]
>
>
> You'll notice that the redirect gets cut off via the .aspx. I am aware of
> the Dynamic Content Caching configuration required in records.config and do
> have it on:
>
> CONFIG proxy.config.httpcache.cache_urls_that_look_dynamic INT 1
>
>
> On Sat, Mar 27, 2021 at 4:52 PM Patrick Andrews <comptech1988@gmail.com>
> wrote:
>
>> Standby I did not finish my reply. That is simply the remap rule.
>> Apologies.
>>
>> On Sat, Mar 27, 2021 at 4:51 PM Patrick Andrews <comptech1988@gmail.com>
>> wrote:
>>
>>> Hey Miles,
>>>
>>> Thrilled I got a response so quickly. If you can imagine a
>>> beleaguered sysadmin who's been trying to get this to work for too many
>>> hours now then you've got a good image where I'm at. Here's what I've got:
>>>
>>> a) remap rule is as follows:
>>> [image: image.png]
>>>
>>>
>>> On Sat, Mar 27, 2021 at 4:47 PM Miles Libbey <mlibbey@apache.org> wrote:
>>>
>>>> When you say "redirecting" do you mean returning a 301/302/303/307/308
>>>> status code?
>>>>
>>>> Can you share
>>>> a) the remap rule
>>>> b) a curl with response headers through your ATS instance -- like curl
>>>> -s -IXGET --resolve www.example.com:443:127.0.0.1
>>>> "https://www.example.com/"
>>>> c) a curl with response headers to the origin used (like ATS would send
>>>> to it
>>>> and d) what headers/response you were expecting?
>>>>
>>>> thanks!
>>>> miles
>>>>
>>>> On Sat, Mar 27, 2021 at 1:27 PM Patrick Andrews <comptech1988@gmail.com>
>>>> wrote:
>>>> >
>>>> > I'm having some issues with getting ATS to redirect to a link
>>>> containing .aspx. I am aware of the config setting in records.config and
>>>> dynamic caching and have made the configuration changes as per the
>>>> documentation. When I analyze the redirect via wireshark, however, I am
>>>> still seeing that it's not redirecting properly the entire URL. I have an
>>>> older box running version 6 so I know that at one point it was capable of
>>>> doing so. Is there somewhere else I'm missing or have to configure?
>>>> >
>>>> > Thanks.
>>>>
>>>

Mime
View raw message