uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jay Jarman <jay.jar...@va.gov>
Subject Re: Creating PEAR Files
Date Wed, 10 Feb 2010 18:33:16 GMT
Pablo Duboue <pablo.duboue@...> writes:

> Have you tried refreshing the folder from within eclipse? (F5 keybinding)

I did that and that fixed my problem.  Now I have a new problem.

My AE has a parameter which is a relative file path "/resources/lookup

I use the following two lines of code to get the absolute filename to pass to a

   phrasesFile = (String) uimaContext.getConfigParameterValue(PHRASES_FILE);
   phrasesFile = getClass().getResource(phrasesFile).getFile();

This works fine as long as I have the annotators folder in the classpath for the
CPE manager when I run it.

I created a PEAR and deploy it to another machine and get an error on the first
line of code above.  It says it successfully deployed the annotator and when I
look at it in Window Explorer, everything is in the proper place.  It seems kind
of kluggy that I would have to add to the classpath of the PEAR Installer in
order to install an AE.  Is there a way to get rid of the errors when it
installs the PEAR?  Or a way to turn off it trying to run the initialize method
of my AE when installing the PEAR?

View raw message