uima-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Lally <ala...@alum.rpi.edu>
Subject Re: eclipse plugin version names with dash
Date Mon, 03 May 2010 16:02:12 GMT
On Mon, May 3, 2010 at 11:30 AM, Marshall Schor <msa@schor.com> wrote:

> On 5/3/2010 10:59 AM, Thilo Goetz wrote:
> > Marshall,
> >
> > 2.3.1-SNAPSHOT is not a valid OSGi version number.
>
> I read on the internet (makes it true :-) )   in the reference link
> below that
> "
>
> According to OSGi spec 4.1 section 3.5.2 Bundle-SymbolicName has syntax:
> Bundle-SymbolicName ::= symbolic-name ( ';' parameter ) *
> and in 1.3.2 we see the following:
> symbolic-name ::= token('.'token)*
> token ::= ( alphanum | '_' | '-')+
>
> so '-' is a legal character and therefor eclipse should not warn us
>
> Is this incorrect?  Or is this an OSGi spec back-level compliance issue?
>
>
I think the problem is with the Bundle-Version, not the Bundle-SymbolicName.
 -Adam

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message