Wow--just had an idea as to what might be going on with this nosuchmethoderror stuff.  I replaced Tomcat's XML libraries with the newer xalan and xerces, and also included crimson, and I now have gotten past that error.  Perhaps there's a package collision somehow?  Anyway, that's a problem for the tomcat team -- I think local classes should override system-wide classes....

But--now the servlet is outputing the X11 DISPLAY errors.  Back to the drawing board on this one (there is no X server on the machine running the web server)

Thanks for the info so far....
-Jason



Thierry Kormann <Thierry.Kormann@sophia.inria.fr>
Sent by: Thierry.Kormann@sophia.inria.fr

01/29/2001 01:26 PM
Please respond to Batik Users

       
        To:        Batik Users <batik-users@xml.apache.org>
        cc:        
        Subject:        Re: Rasterizing via API



> When I tried to run the sample you gave off of the command line, I found out
> that it wanted to open up a GUI (I was logged into a remote shell account).
>  When I exported the DISPLAY variable to my local workstation, the rasterizer
> worked beautifully.  (although nothing ever really displayed on screen).  So,
> it seems as if there is some awt or swing code maybe mixed up in there
> somewhere... (?)

good news that it works. That's true that each time you use some AWT classes,
(even if there is no GUI) every thing should work as you will have a GUI
(DISPLAY variable...). It's the fault of the AWT package :(

I think the AWT needs to deal closely with the X server and even start a
dedicated thread (that's why an application using AWT does not quit at the end
of the main method for example and that you have to do a System.exit manually).

> I don't know if this is related to my servlet problem or not -- maybe this is
> just Tomcat's way of gakking on gui stuff?

I haven't tried yet to implement a servlet but I think it should work if every
thing is initialized.


Thierry.

--
Thierry Kormann
email: Thierry.Kormann@sophia.inria.fr  http://www.inria.fr/koala/tkormann/
Koala/Dyade/Bull @ INRIA - Sophia Antipolis

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org