xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent Hardy <vha...@apache.org>
Subject Re: Misplaced Symbols
Date Thu, 31 Jan 2002 17:11:31 GMT
London,

After a quick look, this has to do with the way we are handling the 
transform on the <use>. If you put your use inside a <g> and move the
tranform from the <use> to the <g> you'll see that the result is what
you expect.

I will have a closer look to see if we are doing the right
thing or not. 

Vincent.

London Ontario wrote:
> 
> Hello,
> 
> We are experiencing a problem with Adobe Illustrator 10.0 SVG images when
> loaded into Batik.
> 
> I've attached a small example illustrating the problem.
> The image contains a fish symbol surrounded by a rectangle. In Illustrator
> the fish is properly centered inside the rect, but when the image is loaded
> into Batik the fish leaves his box and appears on top of it.
> 
> This is happening with all our images that include symbol objects.
> 
> Thanks.
> 
> _________________________________________________________________
> Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.
> 
>   ------------------------------------------------------------------------
>                      Name: CenterFish.svg
>    CenterFish.svg    Type: Mozilla Extensible Markup Language Document (text/xml)
>                  Encoding: 8bit
> 
>   ------------------------------------------------------------------------
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: batik-users-help@xml.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org


Mime
View raw message