Sorry i forgot to say that
I'm using Batik 1.5b4 e FOP 0.20.4 on Cocoon 2.0.3