xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anthony J. Starks" <ajsta...@comcast.net>
Subject Squiggle/Mac OS X/JDK 1.4.1 renders differently
Date Tue, 11 Mar 2003 01:40:25 GMT
After upgrading the JVM under Mac OS X from 1.3.1 to 1.4.1 I note some 
odd behavior:

1) It complains about font metrics:

2003-03-10 20:26:49.762 java[440] Font GB18030Bitmap: in 
_readBasicMetricsForSize, claims 0 max advance but is fixed-pitch.
2003-03-10 20:26:53.901 java[440] Warning: Font 
LucidaSans-TypewriterBold claims fixed-pitch with 0 max advance!
2003-03-10 20:26:58.316 java[440] Warning: Font 
LucidaSans-TypewriterBold claims fixed-pitch with 0 max advance!
2003-03-10 20:27:03.655 java[440] Font GB18030Bitmap: in 
_readBasicMetricsForSize, claims 0 max advance but is fixed-pitch.
2003-03-10 20:27:07.385 java[440] Font GB18030Bitmap: in 
_readBasicMetricsForSize, claims 0 max advance but is fixed-pitch.
2003-03-10 20:27:18.162 java[440] Font GB18030Bitmap: in 
_readBasicMetricsForSize, claims 0 max advance but is fixed-pitch.

2) It renders graphics odd.  Under 1.3.1 the following code:

<?xml version="1.0" standalone="no"?>
<svg width="100" height="100"
   xmlns:xlink="http://www.w3.org/1999/xlink">
   <defs>
     <g id="bubble">
       <path d="m0 0
         a 25 25 0 1 0 50 0z" />
     </g>
     <g id="arrow" style="stroke:none">
       <path d="m 0 0
         a 25 25   0 0 0  25 25
         a 25 25 180 0 0 -25 25z"
       />
     </g>

     <g id="mrklogo">
         <use xlink:href="#bubble" transform="translate(25,75)"/>
         <use xlink:href="#bubble" transform="translate(75,25) 
rotate(180)"/>
         <use xlink:href="#bubble" transform="translate(25,25) 
rotate(90)"/>
         <use xlink:href="#bubble" transform="translate(75,75) 
rotate(-90)"/>
         <use xlink:href="#arrow"  transform="translate(25,25)"/>
         <use xlink:href="#arrow"  transform="translate(75,75) 
rotate(180)"/>
       </g>
   </defs>
</svg>

---------

<?xml version="1.0" standalone="no"?>
<svg width="600" height="600"
   xmlns:xlink="http://www.w3.org/1999/xlink">
<g style="fill:rgb(0,140,134)">
<use xlink:href="mrklogo.svg#mrklogo" transform="scale(6.0,6.0)"/>

</g>

</svg>

Renders the logo with no gaps between the elements.   Under 1.4.1 there 
is a gap between the "arrow" and "bubble" elements.

Where is the bug? The JVM? The Code? Batik?

System Details:

Mac OS 10.2.4
Batik 1.5 beta 4




---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org


Mime
View raw message