xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas DeWeese <Thomas.DeWe...@Kodak.com>
Subject Re: SVG-->JPEG vonversion japanese characters
Date Mon, 15 Mar 2004 15:08:54 GMT
GVS Srinivas wrote:

> thanks a lot thomas,
> i am currently using the encoding as
> * <?xml version="1.0" encoding="UTF-8"?> *
> when i use the baove ,adobe svg plugin displayes correctly the japanese 
> characters ,if i convert it as jpeg it doesnt convert the japaense 
> characterss properly.

Ok, can you send a complete standalone file, preferably zipped?
Also a small JPEG of your output might be helpful.

> As per your suggestion i tried using the below encoding 
> encoding="iso-8859-1", but still i face the same problem,and this time 
> even the adobe plugin alsodoesnt display the japanese characters properly.

    Not surprising, I was only using that as an example 8859 is as I
understand it for Western European languages.  I suspected that your
file might be encoded using Shift JIS or some else odd.

> 
> would you please tell where i am going wrong.
> 
> thanks
> 
> GVS
> 
> -----Original Message-----
> From: Thomas DeWeese [mailto:Thomas.DeWeese@Kodak.com]
> Sent: Monday, March 15, 2004 1:27 PM
> To: Batik Users
> Subject: Re: SVG-->JPEG vonversion japanese characters
> 
> 
> Hi GVS,
> 
>    I suspect the problem is encoding.  I don't know
> what encoding '*'テスãƒ'.*' is supposed to be in,
> but for anything above 7bit ASCII you really need
> to provide an XML encoding line otherwise I believe
> it defaults to UTF-8/16.  A standard xml encoding
> line looks something like:
> 
> <?xml version="1.0" encoding="iso-8859-1"?>
> 
>    It must be the first line in the document.
> 
> 
> GVS Srinivas wrote:
> 
>  >
>  >
>  > hi all,
>  > I am using batik JPEG transcoder to convert SVG into an image.
>  > For all the SVG it does fine,when the text element is having some
>  > japanese characters it is not converting the characters and the image
>  > appears with the characters *'テスãƒ'.* I put the following ttf
>  > files(msmincho.ttf,msgothic.ttf) in the jdk path ,but still i face the
>  > same problem.I understand that batik uses ttf2svg.jar for font
>  > conversion,i am not sure how i should tell the JPEG transcoder to use
>  > ttf2svg.jar to convert the fonts properly.please guid me.
>  >
>  > thanks a lot
>  >
>  > GVS
>  > *<svg id="theSVG" width="100%" height="100%" xmlns="*
>  > *http://www.w3.org/2000/svg* *" xmlns:a3="*
>  > *http://ns.adobe.com/AdobeSVGViewerExtensions/3.0/* * " >         
>  >         <g id="world"> <rect id="bg" x="0" y="0"  class="ViewBackGround"
>  > width="100%" height="100%" style="pointer-     events:visible" />
>  >                 <g id='vComponent;59536' transform='translate(40.0
>  > ,1412.5) rotate(0.0)'>
>  >                         <text class='StatuskeyDimensionObjectText'
>  > x='-35.0'  y='2.5' > テスト Number</text>
>  >                 </g>
>  >         </g>
>  > </svg>
>  > *
>  > -
>  >
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: batik-users-help@xml.apache.org
> 
> 
> _____________________________________________________________________
> This e-mail has been scanned for viruses by MCI's Internet Managed 
> Scanning Services - powered by MessageLabs. For further information 
> visit http://www.mci.com
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org


Mime
View raw message