xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Marcano <rob...@marcanoonline.com>
Subject Re: X11 Graphics Env problems on Linux RedHat
Date Wed, 29 Sep 2004 21:06:00 GMT
On Wed, 2004-09-29 at 15:58, Jody Schofield wrote:
> Was anyone had problems using Batik on Linux RedHat?  I have an SVG
> image that i'm rendering into an image that can be displayed in
> eclipse (SWT).  Here is a snippet of the stack trace I'm getting:
> 

It is strange that if you have an X server running this exception is
thrown. You can try to workaround it defining java.awt.headless=true,
but i do not know if this will break the SWT connection to the X Server

> java.lang.InternalError: Can't connect to X11 window server using
> ':0.0' as the value of the DISPLAY
> variable.
>         at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
>         at
> sun.awt.X11GraphicsEnvironment.<clinit>(X11GraphicsEnvironment.java:175)
>         at java.lang.Class.initializeImpl(Native Method)
>         at java.lang.Class.initialize(Class.java:350)
>         at java.lang.Class.forNameImpl(Native Method)
>         at java.lang.Class.forName(Class.java:116)
>         at
> java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:91)
>         at
> java.awt.image.BufferedImage.createGraphics(BufferedImage.java:1073)
>         at
> org.apache.batik.ext.awt.image.GraphicsUtil.createGraphics(Unknown
> Source)
>         at
> org.apache.batik.gvt.filter.GraphicsNodeRed8Bit.genRect(Unknown
> Source)
>         at
> org.apache.batik.gvt.filter.GraphicsNodeRed8Bit.copyData(Unknown
> Source)
>         at
> org.apache.batik.ext.awt.image.rendered.TileCacheRed.genRect(Unknown
> Source)
>         at
> org.apache.batik.ext.awt.image.rendered.AbstractTiledRed.drawBlockInPlace(Unknown Source)
>         at
> org.apache.batik.ext.awt.image.rendered.AbstractTiledRed.drawBlock(Unknown Source)
> at
> org.apache.batik.ext.awt.image.rendered.AbstractTiledRed.copyToRasterByBlocks(Unknown
Source)
>         at
> org.apache.batik.ext.awt.image.rendered.AbstractTiledRed.copyData(Unknown Source)
>         at
> org.apache.batik.ext.awt.image.rendered.TranslateRed.copyData(Unknown
> Source)
>         at
> org.apache.batik.ext.awt.image.rendered.PadRed.copyData(Unknown
> Source)
>         at
> org.apache.batik.gvt.renderer.StaticRenderer.repaint(Unknown Source)
>         at
> org.apache.batik.gvt.renderer.StaticRenderer.repaint(Unknown Source)
>         at
> com.ibm.xtools.gef.internal.render.svg.ImageTranscoderEx.transcode(Unknown Source)
>         at
> org.apache.batik.transcoder.XMLAbstractTranscoder.transcode(Unknown
> Source)
>         at
> com.ibm.xtools.gef.internal.render.svg.SVGImageConverter.setUpTranscoders(Unknown Source)
> at
> com.ibm.xtools.gef.internal.render.svg.SVGImageConverter.renderSVGtoSWTImage(Unknown
> Source)
> at
> com.ibm.xtools.gef.internal.render.svg.SVGImageConverter.renderSVGtoSWTImage(Unknown
> Source)
> 
> 
> The DISPLAY env var is not :0.0.  At first I thought it might be an
> AWT/SWT issue so I created the following test but that seems to work
> fine.
> 
>         BufferedImage buff = new BufferedImage(10, 10,
> BufferedImage.TYPE_3BYTE_BGR);
>         Graphics2D graphics = buff.createGraphics();
>         graphics.dispose();
> 
> any and all help appreciated.
> 
> regards,
> Jody
________________________________________
Robert Marcano


---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org


Mime
View raw message