xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From thomas.dewe...@kodak.com
Subject Re: SVG Marker issue with batik.
Date Wed, 21 Jul 2010 12:17:27 GMT
Hi rms816,

rms816 <rms816.b@gmail.com> wrote on 07/21/2010 03:00:52 AM:

> It is working, but I am facing some problem when svg has the markers 
with
> rotation.
> When I move or drag the element which has the roation attribute, it is
> disappearing on the canvas.
> I guess it is because of the x and y coordinates .

    Sounds like you need to go the Affine Transform school.
Dragging elements with scale/rotation is tricky unless you
have studied your Affine Transforms.



> thomas.deweese wrote:
> > 
> > Hi RMS,
> > 
> > rms816 <rms816.b@gmail.com> wrote on 07/07/2010 12:58:24 AM:
> > 
> >> When I am trying to render the markers on JSVGCanvas,it is coming 
> > properly,
> >> but on mousemove, it is showing NullpointerException at the below 
line.
> > 
> >     I fixed something that may resolve this issue (SVN Rev 961320). 
> > In the future please provide a stand-alone test case if at all 
possible 
> > as it provides a way to check if the problem is really fixed.
> > 
> > 
> > 
> 
> -- 
> View this message in context: http://old.nabble.com/SVG-Marker-
> issue-with-batik.-tp29092689p29222499.html
> Sent from the Batik - Users mailing list archive at Nabble.com.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org
> 


Mime
View raw message