xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John-Val Rose <j...@rosethorn.technology>
Subject RE: AccessControlException when running Batik Squiggle 1.11
Date Fri, 05 Jul 2019 09:17:38 GMT

I understand what you are saying regarding the permissions but Squiggle for Batik 1.9 works
perfectly on the exact same machine.

I’ve checked the file permissions in question and everything appears to be as expected.


From: Kerschbaum Michael<mailto:m.kerschbaum@pke.at>
Sent: Friday, 5 July 2019 18:18
To: batik-users@xmlgraphics.apache.org<mailto:batik-users@xmlgraphics.apache.org>
Subject: AW: AccessControlException when running Batik Squiggle 1.11


I would say, you dont have permission to the file „init.svg“. Perhaps you run the application
from a different user, as the user that created the file ?

Sorry I don’t know Squiggle and the other environment you’re a running batik on. But the
exceptions itself says that the file can’t be read !


Dipl.-Ing. (FH) Michael Kerschbaum

PKE Holding AG
Technologie und Systeme
Computerstraße 6
1100 Wien
T: +43 50150 1210
M: +43 664 80470 1210
F: +43 50150 1042

Aktiengesellschaft mit Sitz in Wien / Firmenbuchnummer 103264i / Ronald Düller - Vorsitzender
des Vorstandes / Bruno Faustka - Mitglied des Vorstandes / Matthias Koppensteiner - Mitglied
des Vorstandes / Klaus Düller - Vorsitzender des Aufsichtsrates
Von: John-Val Rose <john@rosethorn.technology>
Gesendet: Montag, 1. Juli 2019 08:34
An: batik-users@xmlgraphics.apache.org
Betreff: AccessControlException when running Batik Squiggle 1.11

I am new to both Batik and this list so apologies if this question has been asked before.

I have tried to run Squiggle for Batik 1.11 both using the JARs and also via source but each
time I get the attached exception.

It seems to stem from this exception:

java.security.AccessControlException: access denied ("java.net.NetPermission" "setDefaultAuthenticator")
              at java.base/java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)
              at java.base/java.security.AccessController.checkPermission(AccessController.java:1042)
              at java.base/java.lang.SecurityManager.checkPermission(SecurityManager.java:408)
              at java.base/java.net.Authenticator.setDefault(Authenticator.java:130)
              at org.apache.batik.apps.svgbrowser.Main.<init>(Main.java:410)
              at org.apache.batik.apps.svgbrowser.Main.main(Main.java:164)

I am running Squiggle on Windows 10 x64 and have tried with both the latest versions of Java
8 and 12.  I note that this problem does not occur when I tried another version namely Batik

Could someone please help me understand what the nature of this problem is?



View raw message