xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Ford <steven.f...@vanderbilt.edu>
Subject Re: Marker problem
Date Thu, 06 Dec 2001 14:05:36 GMT
Thanks for your response.  The size of the content was the first thing I 
thought of.  I increased it to a ridiculously high size and I got the 
same results except my body was halfway down the page. Anyway, it fit on 
the first two pages.  I only get the problem when my table is larger 
than one page.  Right now I have 2 tables.   The first one fits on one 
page.  the second table starts one page two and flows into page three. 
 It fails on page three.

Keiron Liddle wrote:

> Hi,
>
> The messages about the marker not being added could be due to some 
> minor error like the marker is not the first child of the block or 
> there is whitespace before the marker (markers haven't been fully 
> implemented yet).
>
> The message "Some static content could not fit in the area." indicates 
> that something could not fit into the static area on page three. This 
> may be the real reason that you do not see the marker. You need to 
> increase the size of the static area or reduce the size of the contents.
> Fop does not currently handle this properly, it should (by default) 
> put all the contents there and clip so you only see the specified area.
>
> On 2001.12.05 17:06 Steven Ford wrote:
>
>> I am using a marker to change  the header each time there is a new 
>> 'Center'  in the data.  I get the following error:
>>
>> marker cannot be added to 'org.apache.fop.fo.flow.Block@45064f'marker 
>> cannot be added to 'org.apache.fop.fo.flow.Block@45f572' [1] [2] 
>> [3Warning: Some static content could not fit in the area.]
>>
>> I retrieve the marker in the xsl-region-before. It shows up fine in 
>> the first and second pages but fails in the third. Where it fails is 
>> when a table spans over into a new page.
>>
>> I am displaying data grouped by "Center". each center is in a table 
>> which is in it's own block. At the top of the block I have:
>>
>> <fo:marker marker-class-name="center">
>> Center: 2014450000 - Clinical Chemistry <!-- from database -->
>> </fo:marker>
>>
>> I get 3 pages. the first page is fine, the center has a few rows and 
>> fits on one page. The next center starts on a new page (I use 
>> <fo:block break-before="page">). page 2 is fine but page 3 is a
>> continuation of the block & table that started on page 2 and I get 
>> the above error.
>>
>> Does anyone have an idea what is causing this?
>>
>> PS - If you can't tell by my question I am new to XSL-FO
>>
>>
>



Mime
View raw message