xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willy Reinhardt" <wreinha...@novell.com>
Subject SVG positionning problem
Date Mon, 02 May 2005 17:12:19 GMT
Hi,

I would generate an unordered list with different graphics for each level. To create graphics
I use <fo:instream-foreign-object> with svg tags inside.

result is:

<fo:list-item>
  <fo:list-item-label end-indent="label-end()">
    <fo:block>
      <fo:instream-foreign-object>
        <svg:svg width="10pt" height="10pt">
          <svg:g style="stroke:black; stroke-width:1">
            <svg:circle style="fill:white" cx="5pt" cy="5pt" r="2pt" /> 
          </svg:g>
       </svg:svg>
      </fo:instream-foreign-object>
    </fo:block>
  </fo:list-item-label>
  <fo:list-item-body start-indent="body-start()">
    <fo:block>Niveau 2 puce 2</fo:block> 
  </fo:list-item-body>
</fo:list-item>

For the first level the positionning is correct for each next level the graphic is shifted
to the right and overlap the text.

If I replace the <fo:instream-foreign-object> with <fo:external-graphic sr="..."/>
the source image (jpeg) has been generated from svg tags the positionning is correct.

Have you any idea why an svg graphics isn't positionned as a bitmap graphic ?

Thanks 

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message