xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "s.schwanitz" <s.schwan...@gmx.de>
Subject Problems integrating fonts type1
Date Wed, 15 Nov 2006 09:45:12 GMT
Hi,

i'm trying to integrate a font with fop. but can't manage it. Maybe 
someone could give me a hint.
I actually have two problems:

1. So far I generated the apropriate font xml. This worked fine with 
Bodoni-Italic. The same doesn't work with different "Adobe Caslon" fonts 
I always get the IOException: cannot reset marker. Nevertheless the font 
files seem to be ok.


2. After generating the Bodoni xml file. I edited the fop.xconf as follow:
<renderer mime="application/pdf">
..
<font metrics-url="file:D:/workspace/pdftech/config/bbi.xml" 
kerning="yes" embed-url="file:D:/workspace/pdftech/fonts/bbi_____.pfm">
         <font-triplet name="'Bauer Bodoni'" style="normal" 
weight="normal"/>
         <font-triplet name="'Bauer Bodoni'" style="normal" 
weight="normal"/>
       </font>
..
</renderer>

According to that  the code in my  foTemplate.xsl:

<cid:part1.08070805.04010608@aparzev.com><fo:block-container 
absolute-position="absolute"
                       top="50mm" left="158mm" font-family="'Bauer 
Bodoni'" font-style="normal"
                       color="#ffffff" background-color="#000000" 
font-size="33pt">


But I always get this Warning:                    Font 'Bauer 
Bodoni,normal,400' not found. Substituting with 'any,normal,400'.

I'm using now the fop trunk version.

What am i doing wrong?

Sabine

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message