xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tobias.Solosche...@TIMETOACT.DE
Subject Re: some background-colors in tablecells not shown
Date Tue, 07 Nov 2006 09:36:25 GMT
Ok, may you can give me a hint where Im able to find those classes?!

Thanks for response

Tobias

Jeremias Maerki <dev@jeremias-maerki.ch> wrote on 06.11.2006 13:22:30:

> Indeed. Somewhere the code seems to round up the color value to complete
> white. I guess if you can't upgrade (FOP 0.92 does this correctly),
> you'll have to debug through the code, see where this comes from and fix
> it yourself.
> 
> On 31.10.2006 10:54:28 Tobias.Soloschenko wrote:
> > Hello,
> > 
> > i've got the problem that for example the hex-color-code #f3f3f3 is 
not 
> > shown
> > as background-color in table-cells. I'm using it similar this way:
> > 
> > <fo:table-cell>
> >         <xsl:if test="$bgcolor!=''">
> >                 <xsl:attribute name="background-color"><xsl:value-of 
> > select="$bgcolor"/></xsl:attribute>
> >         </xsl:if>
> >         <!-- I've printed the color value with a block to check it: 
-->
> >         <fo:block><xsl:value-of select="$bgcolor"/></fo:block>
> > </fo:table-cell>
> > 
> > I'm using fop 0.20.5 (now ;) ) and java 1.3 other colors like #339933 
and 
> > #efefef are shown.
> > what could that be?
> > 
> > there are no errors during the compilation and no warning about 
> > background-color properties.
> > I'm using the avalon-logging in debug mode.
> > 
> > kind regards
> 
> 
> 
> Jeremias Maerki
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
> 

Mime
View raw message