xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: Need help with compiling fop beta for java 1.3 - images not working
Date Fri, 15 Dec 2006 12:50:41 GMT
You need to set the JAVA_HOME environment variable to you actually
compile with JDK 1.3.1. You currently compile with a 1.5 class library
and compiler as you can see in the first echos from the build. Be sure
to do an "ant clear" before you build after switching.

On 14.12.2006 14:36:40 jelka.kosir wrote:
> I'm working on a problem I've posted earlier this week and I would need to 
> rebuild fop since I've changed the source.
> 
> I have problems building fop beta 0.92  for java 1.3
> 
> I have jdk1.5.0_06 and Apache Ant version 1.6.5 compiled on June 2 2005.
> 
> I changed the build.properties file (uncommented the two lines that seemed 
> to be correct)
> javac.source = 1.3
> javac.target = 1.3
> 
> I added jimi-1.0.jar in lib folder
> 
> This is what ant prints:
> 
> init-avail:
>      [echo] ------------------- Apache FOP 0.92beta [1999-2006] 
> ----------------
> 
>      [echo] See build.properties and build-local.properties for additional 
> build
>  settings
>      [echo] Apache Ant version 1.6.5 compiled on June 2 2005
>      [echo] VM: 1.5.0_06-b05, Sun Microsystems Inc.
>      [echo] JAVA_HOME: C:\Program Files\Java\jdk1.5.0_06
>      [echo] Jimi Support PRESENT
>      [echo] JAI Support NOT Present
>      [echo] JCE Support PRESENT
>      [echo] JUnit Support NOT Present - Committers are required to have 
> JUnit wo
> rking
>      [echo] XMLUnit Support NOT Present - you can get it from 
> http://xmlunit.sou
> rceforge.net
> 
> init-filters-jdk14:
>      [echo] Use GraphicsConfiguration adapter for JDK 1.4.
> 
> init-filters-jdk13:
> 
> init:
> 
> It seems like my build.properties setting for building java 1.3 does not 
> get recognized and GraficsConfiguration adapter used if for JDK 1.4 
> instead of 1.3
> 
> Build is sucessful but when I use it in my embedded environment on Domino, 
> no images can be rendered, this error is displayed:
> java.lang.NoClassDefFoundError: javax/imageio/ImageIO
> 
> A while ago I had simular problems when building trunk for java 1.3 but 
> the addition of jimi did the trick. 
> 
> Any suggestions ?



Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message