xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Bowditch <bowditch_ch...@hotmail.com>
Subject Re: [ERROR] null while running FOP
Date Tue, 19 Dec 2006 14:21:25 GMT
KS.Bhaskar@iflexsolutions.com wrote:

> Hi,
> 
>  
> 
> I have done transformation of xml to html. I am getting desired output 
> using xalan parer.
> 
> No I have replace html with xsl-fo tags so that I should get pdf output.
> 
>  
> 
> 1)     Is there any site which gives the html equivalent of xsl-fo tags?

A quick search on google revealed the html2fo project:

http://html2fo.sourceforge.net/

BTW, I believe what you are doing is not the best approach. A better 
solution is to generate 2 separate XSLT stylesheets; 1 to transform your 
own XML to HTML and another to tranform the XML to XSL-FO. Creating a 
chain like XML->HTML->XSL-FO means some features may be lost in translation.

> 
> 2)     I am getting null error while parsing. I have attached xsl and 
> xml files please suggests me where is the actual problem.

You dont say what version of FOP you are using?

I had a quick look at your XSLT and there is a typo in the client template:

<xsl:template match="client">
  <fo:block>
    <xsl:value select="name"/>
    <xsl:value select="number"/>
  </fo:block>
  </xsl:template>

The <xsl:value> element doesnt exist. I believe you meant <xsl:value-of>

BTW, this is a pure XSLT problem, which you would have spotted yourself 
if you ran the XSLT in a separate step before presenting FOP with the 
XSL-FO. If you call FOP with an XML and XSL file then it calls xalan to 
generate the XSL-FO first.

Chris




---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message