xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: Problem rendering PNG Issue
Date Thu, 06 Mar 2008 19:29:16 GMT
Grmbl, grmbl. Had you found this bug about 4 days earlier it would have
made it into the XML Graphics Commons release 1.3. Now we probably have
to do a bugfix release. (Not your fault!!! Thanks for the bug report!)

Bugfixed in Commons Trunk:
http://svn.apache.org/viewvc?rev=634385&view=rev

You can, as a work-around, edit the PNG file in some bitmap editor and
add some metadata to it so its size increases a bit. You only need about
4 bytes more and the PNG will run through with no error.

On 06.03.2008 19:56:55 Puppala, Kumar (LNG-CON) wrote:
> I am trying to render a PNG image using the new FOP Trunk code and I am
> getting the following error in the log:
> 
>  
> 
> ERROR org.apache.fop.fo.FONode : I/O error while loading image: null
> 
>  
> 
> I am attaching the particular PNG image in question (the image by itself
> is good and it opens up properly). I rendered the same image
> successfully using 0.20.5 version. When I debugged the code, the
> exception that was caught in ExternalGraphic.java was EOFException with
> no message. Any help is greatly appreciated.
> 
>  
> 
> Thanks,
> 
> Kumar
> 




Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message