xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: How to create version 2.0 PS files
Date Wed, 01 Apr 2009 09:20:22 GMT
Hi Adrian & Frank,

please note that "%!PS-Adobe-3.0" does not refer to the PostScript
language level but to the version of the DSC specification which is 3.0.
The language level is given by the following DSC comment:

%%LanguageLevel: 2

So this is no bug.

On 01.04.2009 11:11:30 Adrian Cumiskey wrote:
> Hi Frank,
> 
> I don't think you are missing anything, I think it may be a bug.  Having 
> stepped through the code, "%!PS-Adobe-3.0" is always written as the 
> first line of the header regardless of the language level.  Could you 
> please send us a bug report at 
> https://issues.apache.org/bugzilla/enter_bug.cgi?product=Fop and someone 
> will take a look at the problem.  I'll try to find some time later this 
> week.
> 
> Thanks,
> 
> Adrian.
> 
> Frank Niedermann wrote:
> > Hi Adrian,
> >
> > thanks for the link. This is my fopConfiguration.xml file:
> > <fop>
> >   <renderers>
> >     <renderer mime="application/postscript">
> >       <auto-rotate-landscape>true</auto-rotate-landscape>
> >       <language-level>2</language-level>
> >     </renderer>
> >   </renderers>
> > </fop>
> >
> > And this is how I load this configuration file:
> > String fopConfiguration = "fopConfiguration.xml";
> > FopFactory fopFactory = FopFactory.newInstance();
> > fopFactory.setUserConfig(new File(fopConfiguration));
> > FOUserAgent foUserAgent = fopFactory.newFOUserAgent();
> >
> > But it still creates version 3 PS-files (I checked the header).
> >
> > Am I missing something else?
> >
> > Thanks,
> >   Frank
> >
> >
> > Adrian Cumiskey-2 wrote:
> >   
> >> Hi Frank,
> >>
> >> Yes, you can do this with the language-level configuration option (see 
> >> http://xmlgraphics.apache.org/fop/0.95/output.html#ps-configuration).
> >>
> >> Adrian.
> >>
> >> Frank Niedermann wrote:
> >>     
> >>> Hi,
> >>>
> >>> we are using Apache FOP to create PS files which should be printed on a
> >>> HP-Unix machine.
> >>>
> >>> Unfortunately this machine only supports version 2.0 PS files:
> >>> %!PS-Adobe-2.0
> >>>
> >>> Apache FOP creates version 3.0 PS files which are ignored by the HP-Unix
> >>> print system.
> >>>
> >>> Is there a way to tell FOP to generate version 2.0 PS files?
> >>>
> >>> Thanks,
> >>>   Frank
> >>>
> >>>   
> >>>       



Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message