xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Delmelle <andreas.delme...@telenet.be>
Subject Re: Problems with DOMSource
Date Mon, 06 Apr 2009 16:13:15 GMT
On 06 Apr 2009, at 13:36, Sam Fuqua wrote:

Hi

> I'm using fop .94.  I'm reading in a .fo file, which is then  
> manipulated by adding more fo that is generated to the flow "xsl- 
> region-body".  When I try to transform the DOMSource, I get two  
> errors: that the root node is not a valid root node and that it must  
> be "fo:root", and that "fo:block" is not a valid child of "block".   
> However, if I turn the DOMSource into a string, everything works  
> fine and I get no errors.  I really need to use as DOMSource rather  
> than a string, though.  Has anybody had a similar problem?

Yes, in another (non-FO) context. Most likely this is related to  
namespaces. Are you adding the elements in the correct namespace, or  
do you just add the 'fo:' prefix and expect that this will magically  
take care of putting the node in the correct namespace?
In the latter case, tough luck, I'm afraid. You have to take care that  
the additional nodes are added with the correct namespace /URI/ (the  
prefix should be irrelevant).

HTH!

Andreas

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message