xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Delmelle <andreas.delme...@telenet.be>
Subject Re: Font registration
Date Tue, 07 Apr 2009 17:32:50 GMT
On 07 Apr 2009, at 17:39, Steve Ebersole wrote:

Hi Steve

> I tried a mixture of the two.  I have a problem though.
> FontInfoFinder.find is returning me null. Basically I have a directory
> of fonts (.ttf and .ttc).  I was trying the following code fragment
> (which is where FontInfoFinder.find is returning null):
> <snip />
>
> So basically, for each direcrtory containing fonts
> (environment.getFontDirectories()), I iterate the files
> (fontDirectory.listFiles()).  So fontFile is the .ttf files.  I have
> verified this in debugger.  Yet when fontInfoFinder.find is called on
> that .ttf file, it returns null.

Most likely an issue with the TTF file. FOP still chokes on some TTFs  
(mostly on Linux and Mac OS, or OTF variants)
Do you get any log output indicating such a problem?

Checking the code, FontInfoFinder.find() will return null if:
* there is a FontCache and the file has failed to load on a previous  
attempt. We only display the corresponding message if the log-level is  
set to DEBUG.

* the file failed to load, but it is the first attempt. In FOP Trunk,  
a message is then broadcast to the attached EventListener (if it has  
been registered).


HTH!

Andreas


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message