xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Delmelle <andreas.delme...@telenet.be>
Subject Re: Fop Error with unknown element
Date Thu, 09 Apr 2009 21:09:25 GMT
On 09 Apr 2009, at 22:47, Sam Fuqua wrote:

Hi Sam

> I'm getting a strange fop error that I can't figure out why I'm  
> getting it.
> The error is this:
>
> ERROR:  'Error(Unknown location): fo:block is not a valid child
> element of fo:table-row.'
>
> My XSL is at the bottom.

Well, the XSL itself will not really help you to track this down.

What you'll need to do is dump the resulting FO to disk somewhere, and  
then either run it through FOP using the command-line interface or  
open the file in an XML editor to search for it using XPath (//table- 
row[block]).
If you just re-run it from command-line, the error message above will  
point you to the actual location in the file. The downside is that  
there may be more of those after that, and you will have to repeat the  
procedure until all occurrences are eliminated. Using an XML editor,  
you can at least identify the whole set of offending nodes in one go.

Knowing where exactly those situations occur, should give you a clue  
on how to prevent it from happening.



HTH!


Andreas

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message