xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Delmelle <andreas.delme...@telenet.be>
Subject Re: Font registration
Date Wed, 08 Apr 2009 16:54:49 GMT
On 08 Apr 2009, at 15:21, Steve Ebersole wrote:

Hi Steve

> So there is obviously still something I am missing:
> 1) Told FOP about the fonts (via DefaultConfiguration ->
> FopFactory.userConfig)
> 2) Set the defined DocBook font family xslt params
> ('monospace.font.family', et al).
> 3) ???

Can you perform the XSLT transform and send us the resulting FO? Maybe  
something in there tells us why you're getting the missing glyphs.  
(unless of course, you already confirmed that it works from the  
command-line...)

Without looking at the FO result, I'm suspecting that, since you're  
now working with 0.95, there is still no automatic font-selection  
available. If the first font in the specified list of families does  
not contain the glyph, then FOP 0.95 will not yet look at the  
remaining specified fonts. FOP Trunk already contains basic support  
for font-selection-strategy (= will render a word in the font that can  
correctly display most or all of the glyphs, if such a font is  
specified and available).

Another option would be to render the same XML+XSLT with FOP Trunk. If  
that works, then the above is the most likely cause. If not, then we  
have to look elsewhere.



Regards

Andreas

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message