xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexey Neyman <sti...@att.net>
Subject Re: FOP 0.95 - bug with tables?
Date Tue, 14 Sep 2010 05:52:17 GMT
I found a workaround for this. An zero-width column can be added to the table:

<fo:table-column column-width="proportional-column-width(0)"/>

And then, add <fo:table-cell><fo:block>&#160;</fo:block></fo:table-cell>
to 
the problematic row. This causes a warning about area overflow, but looks 
okay.

Ugly, but at least it works...

Regards,
Alexey.

On Monday, September 13, 2010 02:12:34 pm Alexey Neyman wrote:
> Actually, test case can be reduced even more. Desired result:
> 
> AB
> AC
> DC
> 
> Essential XSL-FO code:
> 
> <fo:table>
>  <fo:table-body>
>   <fo:table-row>
>    <fo:table-cell number-rows-spanned="2">
>     <fo:block>A</fo:block>
>    </fo:table-cell>
>    <fo:table-cell>
>     <fo:block>B</fo:block>
>    </fo:table-cell>
>   </fo:table-row>
>   <fo:table-row>
>    <fo:table-cel number-rows-spanned="2">
>     <fo:block>C</fo:block>
>    </fo:table-cell>
>   </fo:table-row>
>   <fo:table-row>
>    <fo:table-cell>
>     <fo:block>D</fo:block>
>    </fo:table-cell>
>   </fo:table-row>
>  </fo:table-body>
> </fo:table>
> 
> Got result (see attached 1.fo and 1.pdf):
> 
> AB
> DC
> 
> Is it a bug?
> 
> Regards,
> Alexey.
> 
> On Monday, September 13, 2010 01:39:06 pm Alexey Neyman wrote:
> > Hi All,
> > 
> > I am trying to format a table with cells spanning as shown below:
> > 
> > AAB
> > AAC
> > DEC
> > 
> > To do this, I am using attached .fo file (it is actually a stripped-down
> > DocBook-generated table). The essential piece is:
> > 
> > <fo:table>
> > 
> >  <fo:table-body>
> >  
> >   <fo:table-row>
> >   
> >    <fo:table-cell number-rows-spanned="2" number-columns-spanned="2">
> >    
> >     <fo:block>A</fo:block>
> >    
> >    </fo:table-cell>
> >    <fo:table-cell>
> >    
> >     <fo:block>B</fo:block>
> >    
> >    </fo:table-cell>
> >   
> >   </fo:table-row>
> >   <fo:table-row>
> >   
> >    <fo:table-cell number-rows-spanned="2">
> >    
> >     <fo:block>C</fo:block>
> >    
> >    </fo:table-cell>
> >   
> >   </fo:table-row>
> >   <fo:table-row>
> >   
> >    <fo:table-cell>
> >    
> >     <fo:block>D</fo:block>
> >    
> >    </fo:table-cell>
> >    <fo:table-cell>
> >    
> >     <fo:block>E</fo:block>
> >    
> >    </fo:table-cell>
> >   
> >   </fo:table-row>
> >  
> >  </fo:table-body>
> > 
> > </fo:table>
> > 
> > However, it gets rendered like this:
> > 
> > AAB
> > DEC
> > 
> > (there is no row that includes both A-cell and C-cell). See the attached
> > PDF. It looks like a bug; could somebody confirm and suggest a
> > fix/workaround?
> > 
> > PS. Using FOP 0.95, Ubuntu 10.04.
> > 
> > Regards,
> > Alexey.

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message