xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pascal Sancho <pascal.san...@takoma.fr>
Subject Re: &#x200b; (Zero width space) not work
Date Wed, 23 Nov 2011 09:19:09 GMT
Hi Pedro,

I see no ZWSP in your file.
you can insert it by hand directly in your FO, just before each
fo:retrieve-marker, then check if output is correct.
If yes, then have a look into your XSLT or XSLT engine (I don't know
witch engine you use).

If no, re-attach moddified XSL-FO, this including ZWSP.

Le 23/11/2011 09:09, pedro a écrit :
> 
> Hi i can add a file, is not very short because this "bug" is visible if there
> is two pages document! http://old.nabble.com/file/p32873641/fo.xml fo.xml 
> 
> Pascal Sancho wrote:
>>
>> Can you post a [short] XSL-FO (not XSL-T) that demonstrates the issue?
>> I cannot reproduce what you describe.
>>
>> Le 22/11/2011 14:16, pedro a écrit :
>>>
>>> I use fop 0,95 and the output is a pdf that i open with Acrobat X or
>>> Foxit
>>> Redaer.
>>>
>>> Pascal Sancho wrote:
>>>>
>>>> Pedro,
>>>>
>>>> what is the output? PDF, XSL-FO, other?
>>>> whitch tool (and version) do you use to see it?
>>>>
>>>> I suspect this is a viewer issue, FOP works fine with such character.
>>>>
>>>> Note that [disable-output-escaping="yes"] is only for &lt; or &amp;,
and
>>>> its use is discourged by good practices.
>>>>
>>>>
>>>> Le 22/11/2011 12:11, pedro a écrit :
>>>>>
>>>>> Hi all 
>>>>>   i use the &#x200b; character in a table cell before i call a
>>>>> marker-retriever to workaround a bug(the solution is good), but the
>>>>> proble
>>>>> is that &#x200b; characher is printed like a "?" while i think isn't
a
>>>>> printable character.
>>>>> Ani idea?
>>>>>
>>>>>
>>>>> [code]
>>>>> <fo:table-cell>
>>>>>   <fo:block font-family="Courier" font-size="8pt"
>>>>>       text-align="center">
>>>>>     <xsl:text disable-output-escaping="yes">&#x200b;</xsl:text>
>>>>>     <fo:retrieve-marker
>>>>>         retrieve-class-name="contr-conai"
>>>>>         retrieve-position="last-ending-within-page"
>>>>>         retrieve-boundary="page-sequence"/>
>>>>>   </fo:block>
>>>>> </fo:table-cell>
>>>>> [/code]
>>>>>
>>>>>
>>>>> i try also to put &#x200b; directly in block or with ZWNJ  and doesn't
>>>>> work.
>>>>
>>>>
>>>> -- 
>>>> Pascal
>>
>> -- 
>> Pascal

-- 
Pascal

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message