xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Klearchos Klearchou <klearchos.klearc...@eurodyn.com>
Subject Re: Multi threading problems with FOP 1.0
Date Wed, 23 Nov 2011 12:44:39 GMT
Hello,

I found this link related to SVG: 
http://xmlgraphics.apache.org/fop/trunk/graphics.html#svg
based on that I use this:
<fo:external-graphic src="url('{$link}')"  content-width="scale-to-fit" 
width="20mm" />

The link is an absolute path to a JPEG file.

This erroneous behaviour happens not only at the URI of the image but in 
other places.
For example I have hard-coded in my XSLT the following '8pt' and the 
generated FO contains the problematic 'pt8pt'.
I print the whole FO when an error happens in order to check it.

Please let me know if you need more information.

Regards,
Klearchos


On 11/23/2011 2:18 PM, Peter Coppens wrote:
> Hello
>
> I have similar things but as far I can remember this was always related to svg as part
of an fo stylesheet.
>
> I should/could dive into the mail archives (and perhaps) bugzilla to refresh my memory,
as I remember there were discussion on this, but perhaps you can indicate whether you are
using svg at all in your fo?
>
> Peter
>
>
> On 23 Nov 2011, at 12:12, Klearchos Klearchou wrote:
>
>> Dear FOP users,
>>
>> I am using the FOP version 1.0 under Windows x64.
>> Lately I have integrated JPPF in order to regenerate my PDFs faster and I experience
the followings strange errors.
>>
>> For example inside the XSLT I place 8pt but the error in the console outputs (pt8pt):
>> [ERROR][org.apache.fop.fo.properties.PropertyMaker.convert(148)]: Unknown length
unit 'pt8pt'
>>
>> This kind of behaviour happens at other places as well:
>> [ERROR][org.apache.fop.apps.FOUserAgent.processEvent(82)]: Invalid property value
encountered in color="whitewhite": org.apache.fop.fo.expr.PropertyException: null:56:15: No
conversion defined whitewhite; property:'color' (See position 57:85)
>> Only white at the XSLT.
>>
>> [ERROR][org.apache.fop.apps.FOUserAgent.processEvent(82)]: Invalid property value
encountered in background-color="#6777cf#6777cf": org.apache.fop.fo.expr.PropertyException:
null:56:15: No conversion defined #6777cf#6777cf; property:'background-color' (See position
57:100)
>>
>> [ERROR][org.apache.fop.apps.FopFactory.resolveURI(755)]: Attempt to resolve URI 'F:\JPF:\JPPF\Node1\resources\images\na_b.gif')'
failed:
>> Here the URI is given correctly at the XSLT processor: F:\JPPF\Node1\resources\images....
>>
>> These kind of errors continue.
>>
>> Any pointer would be really helpful.
>> I am considering using the trunk version as well in order to close some other reported
and patched bugs of FOP 1.0
>>
>> Regards,
>> Klearchos
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
>> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>



---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message