xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Steiner" <simonsteiner1...@gmail.com>
Subject RE: FOP 1.1 - Unable to break line in PDF
Date Tue, 26 Feb 2013 09:04:39 GMT
Hi,

What about using

<fo:block white-space-treatment="preserve" white-space-collapse="false"
linefeed-treatment="preserve"> 
Text

text

 </fo:block>

Thanks

-----Original Message-----
From: Neeraj [mailto:neerajiiita@gmail.com] 
Sent: Thursday, February 21, 2013 2:04 PM
To: fop-users-help@xmlgraphics.apache.org; fop-users@xmlgraphics.apache.org
Subject: FOP 1.1 - Unable to break line in PDF

Hi,

I have a xml file which is having some text with line break. After
generating  PDF i am loosing the line break. I tried different combinations
but it is not working.

Actually after generating XSL-FO file, i checked it is not having line
break.

I tried for char '&#xA;' and added a fo-block for line break. but not able
to find this char in string.

linefeed-treatment="preserve" is also used.

I am posting all files, including PDF, FO-Output and XSL file.

Actually this all working when Line1 and Line2 are inside title tag.

<Books>
  <Book>
    <Title>
Line 1
Line 2
      </Title>
  </Book>
</Books>

Any help would be appreciated.

Thanks
Neeraj


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message