xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Wicentowski <joe...@gmail.com>
Subject Re: Distiller errors with postscript generated by FOP
Date Mon, 14 Apr 2014 23:11:42 GMT
Hi Robert,

Thanks so much for your quick reply.  I changed optimize-resources
from false to true, and while Distiller no longer complains about
Times and Courier, it is complaining about Helvetica.  Checking the
.ps file, I see Times and Courier are no longer referenced, but
Helvetica is.  It's not explicitly identified in my .fo file, and I
didn't intend for Helvetica to be there; I wonder if it's lurking
because of some block that lacks an explicit font-family?

If it helps, I've uploaded the resulting .ps file to:

http://static.history.state.gov.s3.amazonaws.com/temp/frus-history-optimize-resources-true.ps

Thanks,
Joe


On Mon, Apr 14, 2014 at 6:35 PM, Robert <rmeyer@hotmail.co.uk> wrote:
>
> Hi,
>
> From a quick glance the font still seems to be included in the postscript file even though
you've commented it out. I'll take a look at this tomorrow to see if I can reproduce.
>
> In the meantime however, to try and resolve your problem change the <optimize-resources>false</optimize-resources>
underneath the application/postscript renderer section in the fop.xconf to true. That should
strip out any unused fonts listed in the config file from the output.
>
> I'll investigate more tomorrow if you're still having issues.
>
> Regards,
>
> Robert Meyer
>
> ________________________________
> From: joewiz@gmail.com
> Date: Mon, 14 Apr 2014 18:13:24 -0400
> Subject: Distiller errors with postscript generated by FOP
> To: fop-users@xmlgraphics.apache.org
>
>
> Hi all,
>
> A belated thanks for the response to my previous question about using Adobe Distiller
with postscript output from Apache FOP.
>
> I am hitting a new issue, in which Adobe Distiller gives me an error when I give it a
.ps file generated by Apache FOP, but only when I use Distiller's Press Quality setting. 
With Distiller's Standard setting, I don't get an error - presumably because Standard isn't
as strict about the font issue reported in the log:
>
> ----
> %%[ Error: Times-BoldItalic not found. Font cannot be embedded. ]%%
> %%[ Error: invalidfont; OffendingCommand: findfont ]%%
>
> Stack:
> /Font
> (Times-BoldItalic)
>
> %%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
> %%[ Warning: PostScript error. No PDF file produced. ] %%
> ----
>
> What's strange is that I don't even use Times in this file.  The only font I use in my
.fo file is Palatino Linotype.
>
> Has anyone encountered this error before with Distiller?
>
> For more context, I generated the .ps file on the Mac, using FOP trunk (latest).  I was
using Distiller from Acrobat Pro XI on Windows 7.  If it's useful, I've posted the .fo, fop.config
and .ps files at the links below:
>
> http://static.history.state.gov.s3.amazonaws.com/temp/frus-history.fo
> http://static.history.state.gov.s3.amazonaws.com/temp/frus-history-original.ps
> http://static.history.state.gov.s3.amazonaws.com/temp/frus-history-with-times-and-courier-defined.ps
> http://static.history.state.gov.s3.amazonaws.com/temp/fop-config.xml
>
> The 'original' ps file uses the fop-config.xml as is.  The 'with-times-and-courier-defined'
version uses the same config file, but with the times and courier entries uncommented.  The
times and courier entries were my attempt to force FOP to embed Courier and Times from the
Mac, since they both appeared in Distiller errors.  But embedding these didn't help.
>
> My inclination is to try to strip the .ps file of any unused fonts, but I haven't been
able to figure out how to do this.
>
> Thanks in advance for any suggestions.
>
> Joe

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message