xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lembit Gerz <Lembit.G...@nortal.com>
Subject RE: Encoding problem with one specific letter and postscript
Date Tue, 28 Oct 2014 18:18:55 GMT
Hi Chris

Thank you for your reply. Unfortunately, the problem persists. I have attatched a minimal
set of files to reproduce the problem.
Here's what I did:
Downloaded the trunk version and ran "ant all".
Placed the contents of fopp.zip to the fop root directory.
Ran "fop -xml name.xml -xsl name2fo.xsl -ps name.ps -c fop-config.xml"
Ran "ps2pdf name.ps name.pdf"
I also tried with ohter fonts like Verdana and Times New Roman, but the two problematic letters
still appear as boxes.
If I remove the "single-byte" encoding, all the letters are displayed correctly, but then
I cannot copy any of the Lithuanian letters from the PDF.



-----Original Message-----
From: Chris Bowditch [mailto:bowditch_chris@hotmail.com] 
Sent: 27. oktoober 2014. a. 18:21
To: fop-users@xmlgraphics.apache.org
Subject: Re: Encoding problem with one specific letter and postscript

Hi Lembit,

Sorry for slow reply, I've been on holiday. You really need to add


element to your fop.xconf file in the Postscript Renderer section. 
Without that FOP can't accurately judge which characters can be subset or not.

Adding encoding-mode attribute will circumvent the subset issue because it will embed up to
256 characters, but since you are using a wide range of characters that probably isn't enough.

I also recommend testing the Trunk version if that doesn't resolve your issue, since a lot
of bugs have been fixed since v1.1 was released.



On 12/10/2014 20:16, Lembit Gerz wrote:
> Hello,
> I am using FOP 1.1 to generate postscript files with embedded fonts. 
> Later I’m using ps2pdf to convert the postscript files to pdfs. The 
> text includes Lithuanian letters.
> However, after coverting them to pdf, two specific letters are 
> displayed as squares, all the ohter Lituhuanian letters are displayed 
> correctly. The problematic letters are the upper- and lowercase 
> letters ė and Ė (e with dot, 0116 and 0117 in unicode). I can copy all 
> the letters from the pdf (including the two problematic ones – when 
> copying the square and pasting it somewhere, it displays the letter 
> correctly).
> I am using the standard Arial font from Windows fonts (arial.ttf).
> This is my fop-config.xml:
> <configuration>
>     <renderers>
>         <renderer mime="application/postscript">
> <auto-rotate-landscape>true</auto-rotate-landscape>
>            <fonts>
>                <font embed-url="./arial.ttf" 
> encoding-mode="single-byte">
>                    <font-triplet name="Arial" style="normal" 
> weight="normal"/>
>                </font>
>            </fonts>
>         </renderer>
>     </renderers>
> </configuration>
> When leaving out the encoding-mode=“single-byte“, the letters display 
> correctly, but when copying from the pdf, I get gibberish.
> When generating straight to pdf with FOP, everything is displayed 
> correctly and copying is also possible.
> I have tried other ps->pdf converters and they give the same result.
> Using a metric file did not help.
> The problem can be reproduced with the xml and xslt in the fop quick 
> start guide (https://xmlgraphics.apache.org/fop/quickstartguide.html)
> with these modifications:
> Set the name in name.xml to ABC14pąęčėųūĘĖŲČĄ.
> Add the attribute font-familiy=“Arial“ to the fo:block in name2fo.xsl.
> Use the above fop-config file and include the standard Arial font in 
> FOP’s directory.
> Run ’fop -xml name.xml -xsl name2fo.xsl -ps name.ps -c fop-config.xml’
> Can anyone suggest, what could be the issue or how should I go about 
> debugging this?
> Thank You.
> Lembit

To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org

View raw message