Hello,

 

I am using FOP 1.1 to generate postscript files with embedded fonts. Later Im using ps2pdf to convert the postscript files to pdfs. The text includes Lithuanian letters.

However, after coverting them to pdf, two specific letters are displayed as squares, all the ohter Lituhuanian letters are displayed correctly. The problematic letters are the upper- and lowercase letters and (e with dot, 0116 and 0117 in unicode). I can copy all the letters from the pdf (including the two problematic ones when copying the square and pasting it somewhere, it displays the letter correctly).

I am using the standard Arial font from Windows fonts (arial.ttf).

This is my fop-config.xml:

<configuration>

    <renderers>

        <renderer mime="application/postscript">

           <auto-rotate-landscape>true</auto-rotate-landscape>

           <fonts>

               <font embed-url="./arial.ttf" encoding-mode="single-byte">

                   <font-triplet name="Arial" style="normal" weight="normal"/>

               </font>

           </fonts>

        </renderer>

    </renderers>

</configuration>

 

When leaving out the encoding-mode=single-byte, the letters display correctly, but when copying from the pdf, I get gibberish.

When generating straight to pdf with FOP, everything is displayed correctly and copying is also possible.

I have tried other ps->pdf converters and they give the same result.

Using a metric file did not help.

 

The problem can be reproduced with the xml and xslt in the fop quick start guide (https://xmlgraphics.apache.org/fop/quickstartguide.html) with these modifications:

Set the name in name.xml to ABC14p.

Add the attribute font-familiy=Arial to the fo:block in name2fo.xsl.

Use the above fop-config file and include the standard Arial font in FOPs directory.

Run fop -xml name.xml -xsl name2fo.xsl -ps name.ps -c fop-config.xml

 

Can anyone suggest, what could be the issue or how should I go about debugging this?

Thank You.

 

 

Lembit