xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Ogan <e...@change.org>
Subject Re: Ligation Issues in Arabic & Devanagari
Date Thu, 06 Apr 2017 16:41:11 GMT
Thanks for your quick response! Let me reply inline:

On Thu, Apr 6, 2017 at 8:10 AM, Glenn Adams <glenn@skynav.com> wrote:
> Firstly, don't specify any script property, or if you do, set it to "dflt".
> Try that and see what happens.

I really only added scripts as a last-ditch attempt, in the hope that
Claudius Teodorescu’s email was the answer for which I’d been looking.
Most of my attempts to make this work did not include them.

I’ll try setting it to “dflt” now, just to see if it helps, but
otherwise I’ll leave them out.

> Secondly, there are many Noto Sans fonts, so you may have to specify a
> different font to be applied to specific scripts.

Sorry, I should have been more precise. I’m using Noto Sans as my
_typeface_, I’m using the various fonts for each of these scripts. For
example I’m using NotoNaskhArabic-{Regular,Bold}.ttf for Arabic, and
NotoSansDevanagari-{Regular,Bold}.ttf for Devanagari.

> Thirdly, note that Devanagari has never been fully completed, so there are a
> few known bugs.

Interesting. It was working well enough for my test content in the PDF
produced in 2015. Perhaps after this is all released our resident
language expert & I can look into pushing that forward a bit.

-e

-- 
Erik Ogan
erik@change.org
415.BE.MESSY

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message