xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris <bowditch_ch...@hotmail.com>
Subject Re: SVG Arial Font Problem
Date Mon, 14 Oct 2019 15:57:58 GMT
Hi Normen,

It sounds like you are trying to use a glyph that is missing in Arial, 
but it is difficult to comment without seeing your SVG/FO input.

Does FOP output any warnings when rendering the Postscript? I'd expect 
to see a message about missing glyphs

Thanks,

Chris

On 04/10/2019 16:05, Normen Ruhrus wrote:
>
> Hey FOP Gurus,
>
> am working with the excellent FOP 2.2 and wanted to include some SVG. 
> I had no specific font set on that svg:text tag and FOP seemed to 
> autoselect Arial (seems to be default since a test with command line 
> FOP also logs Arial being tried to be used).
>
> The thing is that if i output this into Postscript, the Output looks 
> like this and several characters are replaced with a "Character 
> unknown" Char:
>
> ...
>
> /Arial-BoldMT 6 F
>
> 1 GC
>
> <0001000200030004000500060007>
>
> [4.662 1.998 3.66 1.662 3.336 1.662 0] xshow
>
> ...
>
> If i add the attribute "font-family" with value "Helvetica" to the 
> svg:text node the printer likes the ouput aka output is ok:
>
> <svg:text font-family="Helvetica" 
> style="font-size:6px;font-weight:bold;" x="-24" y="7" fill="white" 
> text-anchor="middle" transform="rotate(270)"><xsl:value-of 
> select="WARNING"/></svg:text>
>
> is translated into:
>
> ...
>
> /Helvetica-Bold 6 F
>
> 1 GC
>
> (\330-hjelp)
>
> [4.668 1.998 3.666 1.668 3.336 1.668 0] xshow
>
> ...
>
> My FOP Font Config for Postscript looks like this:
>
> <font kerning="yes" embed-url="trueType/arial.ttf">
>
> <font-triplet name="Arial" style="normal" weight="normal"/>
>
> </font>
>
> <font kerning="yes" embed-url="trueType/ariali.ttf">
>
> <font-triplet name="Arial" style="italic" weight="normal"/>
>
> </font>
>
> <font kerning="yes" embed-url="trueType/arialbi.ttf">
>
> <font-triplet name="Arial" style="italic" weight="bold"/>
>
> </font>
>
> <font kerning="yes" embed-url="trueType/arialbd.ttf">
>
> <font-triplet name="Arial" style="normal" weight="bold"/>
>
> </font>
>
> Is this a problem of the Arial font, or do i need to investigate 
> somewhere else?
>
> Best Regards
>
> Normen
>
> -------------------------------------------------------------------------------------------
>
> Alphasoft Software Dienstleistungs- und Datenverarbeitungs GmbH
>


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message